Jump to content
Click here if you are having website access problems ×

Hayabusa not charging battery


Recommended Posts

I fixed a fault on my 'busa charging system a few weeks ago. The car hasn't run since, and today I've reconnected the ecu (it went back to MBE for some work), uploaded a map, started the engine again, and I find the charging system is not working again - the battery shows just under 12v while idling.


I've checked the AC output of the stator with the plug disconnected - all three phases show +20v at idle and the voltage increases with revs.


I've checked the resistance of each stator phase - 0.3-0.4 ohms is within spec according to the 'busa manual.


I've checked that none of the phases are shorted to ground.


However, when I plug in the rectifier and measure the phases under load, I'm getting around 2v AC, and about 4.9v DC out of the rectifier.


My previous repair was to replace a burnt plug in the loom at the rectifier end. The new plug still looks fine, and in fact the car hasn't moved from the garage since I did that repair which was, at the time, successful. Today I found that the stator output plug inside the loom was very messy and I was unable to tell whether it was shorted, so I chopped it off and replaced it also, but the problem still remains. The only thing not changed are the wires that join the two connectors I've replaced.


It sounds like a dodgy stator but I'm finding this a bit hard to believe when it worked fine a few weeks ago and the tests all seem to show the stator as working fine until it is under load. Elsewhere in the loom I found a wire had gone high resistance and replacing it fixed a no-spark problem I had a few weeks ago.


I had a new spare rectifier to hand and have tried that to no avail.


Suggestions? Can anything other than a faulty stator cause the AC voltage to drop when the rectifier is plugged in? I suppose I'm trying to avoid taking the stator cover off really!


Edited by - ric355 on 2 Jul 2014 19:03:23

Link to comment
Share on other sites

Ric - when I had a charging problem on my Blackbird, I was pointed at the attached fault-finding guide. Dunno if it will help you: here


I ended up fitting an aftermarket replacement stator (as the Honda one was ridiculously expensive). Managed it all on my own - engine out job on my Westie - didn't half nip my fingers when I put the stator cover back on (boy, are those magnets strong!)

Link to comment
Share on other sites


The gen should put out more than 65V AC on all three phases at 5000rpm - measure in combinations of pairs.


U have checked the stator yellow wires for resistance and presumably the wires on the otherside to the rectifier for resistance. The high current loads can cause these wires to burn out.


Check the black earth from the rectifier all the way to the small one way connector. Test the earths both sides of this connection.


Have u connected all the wiring up and with eng running, what DC voltage are u getting out of the large red wire from the rectifier? Is this 4.9V as u state?



Link to comment
Share on other sites

I had a similar issue early this year for no apparent reason.


It was my rectifier. However an early partial test failed to diagnose/show the issue.


If you email me I can send you the full Busa manual and microfiche. It gives the full test procedure in the manual.

Link to comment
Share on other sites



Thanks for the diagram - will follow it tomorrow if I get time. There are many stories of pinched fingers on the internet!


Timbo -


Unloaded (i.e. rectifier not connected) I'm getting what I think are suitable AC voltages off the stator. Rising with revs and easily going over 40v with "some" revs on (my dash wasn't showing revs at the time, only battery voltage). It's when I connect the regulator back up that it drops to 2v AC between the phases.


I'll check it again tomorrow. 5000 is quite noisy and the oil wasn't very warm so I didn't want to rev it too much. Done the resistance checks you mention and everything seems to be OK but I expect I'll do them again when I follow the guide Myles posted. And yes, the 4.9V DC is the output from the regulator with everything connected up. Same with the the new spare regulator.




This isn't a Caterham by the way, it's an SR3, but I don't think that makes much difference in the context of a charging fault although some of the loom will be different I guess.


Edited by - ric355 on 2 Jul 2014 22:42:22

Link to comment
Share on other sites

Not fixed yet but making some progress. Thanks to Myles' flowchart thingy I quickly identified that there is a "bad connection in positive lead from RR to battery". There is a 70A relay in there that is energised by the ignition switch, and it looks like it has gone pop. Put 12V across it and nothing, and if I shake it something rattles inside so obviously not right.


I've ordered a replacement - seems you can't buy something with terminals that big off the shelf.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...